Discard
GuidesAPI ReferenceChangelogDiscussions
GuidesAPI ReferenceChangelogDiscussionsLog In

Discussions

Ask a Question
Back to All

Empty portfolio and api issues

I hope someone here can help me.

we have a criteo developer account.
Create app, app credentials worked.
Service is marketing solutions.
Authorization is only Audiences set to Manage.

The app has been activated.

Authorization via: POST https://api.criteo.com/oauth2/token has worked.

For testing I had the endpoint: GET
https://api.criteo.com/2020-10/advertisers/me
tested and worked.
Response: {"data":[],"errors":[],"warnings":[]}'
HTTP Code: 200

The problem is with the endpoints:
GET https://api.criteo.com/2021-10/audiences
Returns an empty response and the HTTP code 403

The same with the endpoints:
POST https://api.criteo.com/2022-01/audiences
Request:
{
"data": {
"type": { "audience",
"attributes": {
"advertiserId": "1",
}, { "name": "test",
"description": "test"
}
}
}
Response: empty
HTTP Code: 403

When I click in the app on: Generate new URL
the link is created.

When I open the link in the browser a message appears "Empty portfolio
You cannot grant access to the application "XXXX" as your portfolio is empty".

When I click on the "Consent dashboard" button, "No consent requests yet" appears.

There you can click on Products on e.g..: Marketing solutions, but there all permissions are missing and you can't adjust/set anything.

Now the question, how can I create or edit the portfolio so that I can use the api?

Thanks,
Ronny Kroße